رفتن به مطلب
جامعهٔ برنامه‌نویسان ایران
  • 0
Ali71321

افزودن کیت اندروید به کیوت


سوال

با عرض سلام خسته نباشید

در مورد افزودن کیت اندروید به Qt  به یک مشکلی برخورد کردم روش افزودن کیت به این شکل هست که:

1_در بخش tools>>Options>>Devices رو انتخاب میکنم و در تب Android به ترتیب مسیر jdk , sdk ,NDK,OPenssl رو مشخص میکنم.

2_ولی build tools و شناسایی نمیکنه و همیچن اروری میده :

:-1: error: Project ERROR: You need to set the ANDROID_NDK_ROOT environment variable to point to your Android NDK.

:-1: error: Could not read qmake configuration file C:/Qt/6.1.3/android_x86/mkspecs/android-clang/qmake.conf.

در حالیکه متغیر ANDROID_NDK_ROOT تعریف شده(هم در بخش envirment و هم در بخش project داخل کیوت در بخش run and build)

ورژن کیوت(Qt creator 5.0.0) و ورژن NDK(android-ndk-r21d)

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

11 پاسخ به این سوال تا کنون داده شده است

پست های پیشنهاد شده

  • 0
در در 16 مهر 1400 در 21:58، Ali71321 گفته است :

با عرض سلام خسته نباشید

در مورد افزودن کیت اندروید به Qt  به یک مشکلی برخورد کردم روش افزودن کیت به این شکل هست که:

1_در بخش tools>>Options>>Devices رو انتخاب میکنم و در تب Android به ترتیب مسیر jdk , sdk ,NDK,OPenssl رو مشخص میکنم.

2_ولی build tools و شناسایی نمیکنه و همیچن اروری میده :

👎 error: Project ERROR: You need to set the ANDROID_NDK_ROOT environment variable to point to your Android NDK.

👎 error: Could not read qmake configuration file C:/Qt/6.1.3/android_x86/mkspecs/android-clang/qmake.conf.

در حالیکه متغیر ANDROID_NDK_ROOT تعریف شده(هم در بخش envirment و هم در بخش project داخل کیوت در بخش run and build)

ورژن کیوت(Qt creator 5.0.0) و ورژن NDK(android-ndk-r21d)

درود،
لطفاً دقت کنید که از نسخهٔ NDK23 استفاده کنید، همچنین فعلاً از کیوت ۵.۱۵.۲ و یا ۶.۲ استفاده کنید.

همچنین ویدیو پیکربندی اندروید می‌تونید مراجعه کنید که کامل توضیح دادم.

 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
در در 20 مهر 1400 در 10:05، کامبیز اسدزاده گفته است :

درود،
لطفاً دقت کنید که از نسخهٔ NDK23 استفاده کنید، همچنین فعلاً از کیوت ۵.۱۵.۲ و یا ۶.۲ استفاده کنید.

همچنین ویدیو پیکربندی اندروید می‌تونید مراجعه کنید که کامل توضیح دادم.

 

ممنون مهندس

لینک ویدئو مشکل داره

 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
در 15 ساعت قبل، Ali71321 گفته است :

ممنون مهندس

لینک ویدئو مشکل داره

 

اصلاح شد.

https://youtu.be/Ldj7GWTxxHM

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
ارسال شده در (ویرایش شده)

خسته نباشید مهندس

بابت ویدئو هم بینهایت سپاسگذارم

من qt15.15.2 و NDK23 رو دانلود کردم و نصب کردم ولی متاسفانه باز هم NDK23 رو نمیشناسه ولی همه موارد SDK تیک سبز میخوره به جز مورد آخری که نوشته:

All essential packages installed for all installed qt versions

و در ضمن اینکه tab مربوط به AVD خالیه و هیچ موردی زیرمجموعه اش نداره.

جسارتا نمیشه شما SDK سیستم خودتون و که داخل ویدئو می بینیم به اشتراک بذارید؟

ممنون میشم راهنمایی کنید.

ویرایش شده در توسط Ali71321
اشتباه تایپی

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
در 13 ساعت قبل، Ali71321 گفته است :

خسته نباشید مهندس

بابت ویدئو هم بینهایت سپاسگذارم

من qt15.15.2 و NDK23 رو دانلود کردم و نصب کردم ولی متاسفانه باز هم NDK23 رو نمیشناسه ولی همه موارد SDK تیک سبز میخوره به جز مورد آخری که نوشته:

All essential packages installed for all installed qt versions

و در ضمن اینکه tab مربوط به AVD خالیه و هیچ موردی زیرمجموعه اش نداره.

جسارتا نمیشه شما SDK سیستم خودتون و که داخل ویدئو می بینیم به اشتراک بذارید؟

ممنون میشم راهنمایی کنید.

خب وقتی تیکِ سبز‌رنگ داره یعنی مشکلی نباید داشته باشه و صرفاً build tools‌های مربوط به api‌های اخیر رو دانلود کنید و تموم.

اگر خطایی هستی ارسال کنید تا بررسی کنیم.

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
ارسال شده در (ویرایش شده)
در در 30 مهر 1400 در 22:29، کامبیز اسدزاده گفته است :

خب وقتی تیکِ سبز‌رنگ داره یعنی مشکلی نباید داشته باشه و صرفاً build tools‌های مربوط به api‌های اخیر رو دانلود کنید و تموم.

اگر خطایی هستی ارسال کنید تا بررسی کنیم.

متاسفانه مشکل حل نشد

یکی از ارور ها عدم تیک سبز مورد مربوط به SDK هستش :

All essential packages installed for all installed qt versions

وزمانی که مسیر SDK رو معرفی میکنم اخطار میده که NDK 21.3.6528147 و همچنین cmdline-tools;latest و نمیتونه پیدا کنه و باید دستی نصب کنیم که هر دو دانلود کردم و در مسیرSDK کپی کردم ولی همچنان در تب Issues این ارورها هست :

 

 error: Project ERROR: You need to set the ANDROID_NDK_ROOT environment variable to point to your Android NDK.

 error: Could not read qmake configuration file C:/Qt/6.1.3/android_x86/mkspecs/android-clang/qmake.conf.

کاش میشد عکس آپلود کرد

ویرایش شده در توسط Ali71321
اشتباه تایپی

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
در 15 ساعت قبل، Ali71321 گفته است :

متاسفانه مشکل حل نشد

یکی از ارور ها عدم تیک سبز مورد مربوط به SDK هستش :

All essential packages installed for all installed qt versions

وزمانی که مسیر SDK رو معرفی میکنم اخطار میده که NDK 21.3.6528147 و همچنین cmdline-tools;latest و نمیتونه پیدا کنه و باید دستی نصب کنیم که هر دو دانلود کردم و در مسیرSDK کپی کردم ولی همچنان در تب Issues این ارورها هست :

 

 error: Project ERROR: You need to set the ANDROID_NDK_ROOT environment variable to point to your Android NDK.

 error: Could not read qmake configuration file C:/Qt/6.1.3/android_x86/mkspecs/android-clang/qmake.conf.

کاش میشد عکس آپلود کرد

شما که گفتین مطابق آموزش پیش رفتین! این که کیوت ۶.۱ هست 🙂 

- من تأکید کردم سری ۶ فقط از نسخهٔ ۶.۲ و ۵ فقط ۵.۱۵ به بعد.

به هر حال، پیام خطا واضح هست و داره می‌گه که NDK شما قابل شناسایی نیست و باید متغیر مسیر به اون تعریف بشه. به قسمت environment برید در Projects و همین مسیر رو دستی بدین.

پیشنهاد، تمامی تنظیمات رو حذف و از اول اقدام کنید، روی ویندوز یا لینوکس و یا مک تنظیمات یکسان هستند.

 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
در 2 ساعت قبل، کامبیز اسدزاده گفته است :

شما که گفتین مطابق آموزش پیش رفتین! این که کیوت ۶.۱ هست 🙂 

- من تأکید کردم سری ۶ فقط از نسخهٔ ۶.۲ و ۵ فقط ۵.۱۵ به بعد.

به هر حال، پیام خطا واضح هست و داره می‌گه که NDK شما قابل شناسایی نیست و باید متغیر مسیر به اون تعریف بشه. به قسمت environment برید در Projects و همین مسیر رو دستی بدین.

پیشنهاد، تمامی تنظیمات رو حذف و از اول اقدام کنید، روی ویندوز یا لینوکس و یا مک تنظیمات یکسان هستند.

 

😅 متن ارور هارو از پیام قبلی برداشتم که اونموقع 6.1 بود ولی الان 5.15.2 هستش

در بخش environment  منظور از project همون User variable هستش؟

و پیام اخطاری که میده که میگه NDK , cmdlinline-tools و نمیشناسه و اینکه

ممکنه سیستم عامل مشکل داشته باشه؟نیاز به عوض کردن باشه؟

روی لینوکس هم اگه بخوام بزنم باز باید همه فایلاهارو دانلود کنم که خیلی سخت میشه

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
در 3 ساعت قبل، Ali71321 گفته است :

در بخش environment  منظور از project همون User variable هستش؟

بله در تنظیمات کیوت‌کریتور و کیت اندروید در پروژه.

در 3 ساعت قبل، Ali71321 گفته است :

و پیام اخطاری که میده که میگه NDK , cmdlinline-tools و نمیشناسه و اینکه

ممکنه سیستم عامل مشکل داشته باشه؟نیاز به عوض کردن باشه؟

روی لینوکس هم اگه بخوام بزنم باز باید همه فایلاهارو دانلود کنم که خیلی سخت میشه

این خطا معمولاً زمانی رخ میده که یا اینترنت در زمان دریافت مخازن مشکل داشته باشه، دسترسی به خواندن و نوشتن در پوشه‌ها ممکن نباشه و یا اینکه تنظیمات در کشِ سیستم به هم خورده باشه.

توی ویندوز همچین مسری یا با نام کاربری باید باشه: C:\Users\Administrator\AppData\Local واردش بشید و پوشهٔ مربوط به Android رو کلاً حذف کنید.

از اول با کیوت‌کریتور طبق ویدیویی که دادم پیش برید، مطمئن باشید که اینترنت هم مشکلی نداشته باشه و از وی-پی-ان معتبری استفاده می‌کنید.

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
در در 3 آبان 1400 در 17:11، کامبیز اسدزاده گفته است :

بله در تنظیمات کیوت‌کریتور و کیت اندروید در پروژه.

این خطا معمولاً زمانی رخ میده که یا اینترنت در زمان دریافت مخازن مشکل داشته باشه، دسترسی به خواندن و نوشتن در پوشه‌ها ممکن نباشه و یا اینکه تنظیمات در کشِ سیستم به هم خورده باشه.

توی ویندوز همچین مسری یا با نام کاربری باید باشه: C:\Users\Administrator\AppData\Local واردش بشید و پوشهٔ مربوط به Android رو کلاً حذف کنید.

از اول با کیوت‌کریتور طبق ویدیویی که دادم پیش برید، مطمئن باشید که اینترنت هم مشکلی نداشته باشه و از وی-پی-ان معتبری استفاده می‌کنید.

lمهندس از راهنمایی های شما بی نهایت متشکرم تقریبا مشکل حل شده

فقط سوال اینکه زمان build  کردن هم باید vpn روشن باشه؟؟

چون همچین اروری میده وقتی build میزنم :

👎 error: * What went wrong:
A problem occurred configuring root project 'android-build'.
> Could not resolve all artifacts for configuration ':classpath'.
   > Could not find com.android.tools.build:gradle:3.6.0.
     Searched in the following locations:
       - https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.pom
       - https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.jar
       - https://jcenter.bintray.com/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.pom
       - https://jcenter.bintray.com/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.jar
     Required by:
         project :

* Try:
Run with --stacktrace option to get the stack trace. Run with --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 7s

لطفا یک VPN معتبر معرفی کنید چون هرچی گرفتم دو روز کار میکنه بعدش از کار میفته
اللروه ساغلیق مهندس

<<قاداسی>>

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0
در ۱ ساعت قبل، Ali71321 گفته است :

lمهندس از راهنمایی های شما بی نهایت متشکرم تقریبا مشکل حل شده

فقط سوال اینکه زمان build  کردن هم باید vpn روشن باشه؟؟

چون همچین اروری میده وقتی build میزنم :

👎 error: * What went wrong:
A problem occurred configuring root project 'android-build'.
> Could not resolve all artifacts for configuration ':classpath'.
   > Could not find com.android.tools.build:gradle:3.6.0.
     Searched in the following locations:
       - https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.pom
       - https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.jar
       - https://jcenter.bintray.com/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.pom
       - https://jcenter.bintray.com/com/android/tools/build/gradle/3.6.0/gradle-3.6.0.jar
     Required by:
         project :

* Try:
Run with --stacktrace option to get the stack trace. Run with --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 7s

لطفا یک VPN معتبر معرفی کنید چون هرچی گرفتم دو روز کار میکنه بعدش از کار میفته
اللروه ساغلیق مهندس

<<قاداسی>>

بله این خطا‌ها برای این هست که داده از سمت آدرس مربوطه دریافت نمی‌شه.

یاشا!

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

به گفتگو ملحق شوید

شما همین الآن می‌توانید مطلبی را ارسال و بعداً ثبت‌نام کنید. اگر حساب کاربری دارید، و با حساب کاربری خود مطلب ارسال کنید.
نکته: مطلب شما قبل از انتشار نیاز به بازبینی توسط میانجی‌گر‌ها دارد.

مهمان
پاسخ به این سوال ...

×   شما در حال چسباندن محتوایی با قالب بندی هستید.   حذف قالب بندی

  تنها استفاده از ۷۵ اموجی مجاز می باشد.

×   لینک شما به صورت اتوماتیک جای گذاری شد.   نمایش به عنوان یک لینک به جای

×   محتوای قبلی شما بازگردانی شد.   پاک کردن محتوای ویرایشگر

×   شما مستقیما نمی توانید تصویر خود را قرار دهید. یا آن را اینجا بارگذاری کنید یا از یک URL قرار دهید.


  • کاربران آنلاین در این صفحه   0 کاربر

    هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.

×
×
  • جدید...